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Preface
This eBook is curation of the best explanation and practices on the Power BI tools over the internet which
we like and think that could be helpful to new users. The Purpose of the eBook is to help professionals get
an overview of the Power BI tools, their use case, how to install and few best practices along with
common pitfalls and how to avoid them.
If you’re a complete beginner, you will benefit from the first half of the book on how to get started and If
you know the topic well enough, it will act as a quick refresher for best practices and common pitfalls.
This book should not be read all at once but rather in bits and pieces.
This eBook is not an original work of Yoda Learning. However, we have taken the liberty of modifying the
original author’s work to make it less verbose and more graphical (to be frank, even we hate a lot of
reading). Each curated content pieces has been sourced to the correct author with web-links to find out
more about the content originator.

Getting Started with the Power BI Family
Unofficial Definition = “Umbrella Term for the ‘Power *’ Tools”
Power BI is an “umbrella” term that is used to describe all of
the various “Power” data tools that Microsoft offers us. This is
Not the definition that you will typically hear from Microsoft,
but colloquially, when someone says “Power BI,” there’s a good
chance this is what they mean.
Official Definition = “The Cloud Publish & Manage Service
from MS”
Power BI is Microsoft’s cloud service for publishing, sharing,
managing, and consuming the results of those tools pictured in
this image.

Source: http://projanco.com/Library/Power%20Pivot%20and%20Power%20BI.pdf

Should I use Power Query or Power Pivot or Power View
or Power BI?
Ah, a fair question, but one with a surprisingly
simple answer: you ALWAYS use Power Pivot!
There is, indeed, an entire family of closely-related
Microsoft products in this data analysis and
reporting space, but they all revolve around Power
Pivot. Let’s start simple and then add pieces back
to the puzzle. Power Pivot is the Center of the
Power BI Universe

Power Pivot is the central engine that powers all of
your souped-up workbooks and BI solutions. It is the
brain, the heart, and the spinal cord all in one. We
like to say that Power Pivot is the piece that turns
data into information – feed it “large” quantities of
data (where sometimes even 100 rows is “large”) and
it will help you crunch it down into
meaningful metrics.

Power Pivot is the centerpiece, no matter which
“family members” you’re using!

Source: http://projanco.com/Library/Power%20Pivot%20and%20Power%20BI.pdf

Key benefits of using Power Pivot vs. Basic Excel
•

It lets you import and manipulate hundreds of millions of rows of data where Excel has a hard
constraint of just over a million rows.

•

It allows you to import data from multiple sources into one single source workbook without having
to create multiple source sheets that suffer from version control and transferability issues.

•

It lets you manipulate the imported data, analyze it, and draw conclusions without slowing down
your computer to a snail’s pace.

•

It lets you visualize the data with Pivot Charts and Power BI.

Source: https://www.toptal.com/finance/excel-experts/powerpivot-for-excel-use-cases-and-tutorial

Do you work with data that has been exported from a system of record? This could be a general ledger,
accounting, ERP, CRM, Salesforce.com, or any reporting system that contains data.
If so, you probably spend a lot of time transforming or re-shaping your data to create additional reports,
pivot tables, or charts.
These data transformations could include tasks like:
•

Remove columns, rows, blanks

•

Convert data types – text, numbers, dates

•

Split or merge columns

•

Sort & filter columns

•

Add calculated columns

•

Aggregate or summarize data

•

Find & replace text

•

UnPivot data to use for pivot tables

Source: https://www.excelcampus.com/powerquery/power-query-overview

Power Query is a Close Second in Importance But an
engine needs fuel, and in this case, the fuel is data:
whether big or small, 100 rows or 100 million rows,
coming from the web or a database, a text file or a
spreadsheet. You will want to pull all of your business
data into Power Pivot (not all in one day  of course.
Start small, iterate fast: Power BI is agile BI). So this
brings us to our second-favorite component of the
Power BI family…
Power Pivot can grab data directly from a wide
variety of sources. But sometimes it needs a little
help. Sometimes, before you can bring the data into
Power Pivot, you need to do some shaping, some
cleanup, and maybe some data transformation.
There is a tool built specifically for that – Power
Query. And boy, does it shine at that task. Power
Query is a great way to bring data into Power Pivot.
Source: https://www.excelcampus.com/powerquery/power-query-overview

Power BI Dashboards: Until recently, Excel has been the only “environment” in which the Power BI tools were
available. If you wanted to do some Power Pivot / DAX modeling, you launched Excel and went from there.
But in 2015, Microsoft released a second environment, called Power BI Desktop. Power BI Desktop includes
the two engines (Power Pivot and Power Query), as well as a brand-new visualization layer called Dashboards.

Dashboards looks a bit like Power View, but whereas Power View was somewhat of a frustrating half-step,
Power BI Dashboards are very robust/complete. They offer MANY visualization types that are not available in
native Excel, the list of visualizations grows seemingly with every release, AND they have opened the platform
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programmers can add their own custom visualization types
Source: http://projanco.com/Library/Power%20Pivot%20and%20Power%20BI.pdf

• Integrates seamlessly with existing applications:
Power BI integrates easily with your existing business environment allowing you to adopt analytics and
reporting capabilities. Microsoft Azure consultants can also help you in leveraging this intuitive tool to
embed interactive visuals in your applications easily.
• Rich personalized dashboards:
The crowning feature of Power BI is the information dashboards, which can be customized to meet the
exact need of any enterprise. You can easily embed the dashboards and BI reports in the applications to
provide a unified user experience.
• Publish reports securely:
The tool helps you to setup automatic data refresh and publish reports allowing all the users to avail the
latest information.
• No memory and speed constraints:
Shifting an existing BI system to powerful cloud environment with Power BI embedded eliminates memory
and speed constraints ensuring data is quickly retrievable and analyzed.

Source: http://www.saviantconsulting.com/blog/8-major-benefits-of-microsoft-power-BI.aspx

• No specialized technical support required:
Power BI provides agile inquiry and analysis without the need for specialized technical support. It supports
a powerful natural language interface and the use of intuitive graphical designer tools.
• Extracting business intelligence rapidly and accurately:
It helps in transforming your enterprise data into rich visuals, thus extracting business intelligence for
enhanced decision making.
• Balanced simplicity and performance:
The in-memory analysis technology and DAX scripting language are both exquisite examples of a balance
between simplicity and performance.
• Supports Advanced Data services:
Microsoft Power BI tool can be integrated seamlessly with advanced cloud services like Cortana or Bot
framework. Thus, providing results for the verbal data query given using natural language.

Source: http://www.saviantconsulting.com/blog/8-major-benefits-of-microsoft-power-BI.aspx

Who needs ______ and
Why?

Source: https://exceleratorbi.com.au/who-needs-power-pivot-power-query-and-power-bi-anyway

Who needs Power Pivot and Why?
People that need this tool are typically Microsoft Excel users/report authors that analyze or report on data,
particularly when the following conditions apply:
•

There are lots of data that stretch the capacity of traditional Excel (file size, re-calculation speed etc.) If you
use Pivot Tables a lot to analyze your data.

•

If you are writing a lot of VLOOKUP (or INDEX/MATCH) formulas to join data from different tables so you
can analyze in a Pivot Table.

•

If you have had to create bespoke reports in traditional Excel, but then have to spend hours rebuilding the
report when asked for a different view of the data (e.g. you have a report that shows sales by half year, and
then you are asked to produce the same report by month – and have to start again almost from scratch).

•

Anyone that wants to start using Power BI for anything more than the most simple aggregation reports.
The “out of the box” capabilities of data modelling in Power BI are limited, and you will quickly realize that
you need to learn some new skills (Power Pivot/DAX) to be able to leverage the strengths of Power BI.
Source: https://exceleratorbi.com.au/who-needs-power-pivot-power-query-and-power-bi-anyway

Who needs Power Query and Why?
People that need this tool typically are trying to solve the following problems:
•

They regularly receive file extracts from someone (or some system) and need to manually manipulate
this data before they can use it.

•

They want to use Power BI/Power Pivot but can’t get the IT department to shape the data they need
prior to loading it into Power BI/Power Pivot.

•

People that are doing repetitive tasks such as matching invoices on a remittance advice against a bank
statement (or similar) – Power Query eats this kind of work.

•

Anyone that is given data in the wrong shape (example below). And yes I quickly used Power Query to
un-pivot the data in the blue table so it looked like the green table. It is worth getting and using Power
Query just to get this un-pivot feature alone!

Source: https://exceleratorbi.com.au/who-needs-power-pivot-power-query-and-power-bi-anyway

Who needs Power BI and why?
Power BI will add value to people who:
•

Have problems sharing reports with others because the file size is too large.

•

Need to share data with people on the go, that maybe only have a Tablet or a Mobile phone.

•

Have large data sets that can’t be managed in traditional Excel.

•

Are spending too much time each week/month manually maintaining reports with new source data
and/or new visualization requests.

•

Can’t get the (timely) support they need from their IT department using traditional Enterprise BI tools.

Source: https://exceleratorbi.com.au/who-needs-power-pivot-power-query-and-power-bi-anyway

Download and install
Process for activating PowerPivot
Power Pivot is an add-in that you can use to perform powerful data analysis in Excel. The add-in is built into
certain versions of Office, but by default, it's not enabled.
Here’s how you enable Power Pivot before using it for the first time.
• Go to File > Options > Add-Ins.
•

In the Manage box, click COM Add-ins> Go.

•

Check the Microsoft Office Power Pivot box, and then click OK. If you have other versions of the Power
Pivot add-in installed, those versions are also listed in the COM Add-ins list. Be sure to select the Power
Pivot add-in for Excel.

•

The ribbon now has a PowerPivot tab.

Source: https://support.office.com/en-us/article/start-the-power-pivot-add-in-for-excel-a891a66d-36e3-43fc-81e8-fc4798f39ea8

Download and install
Process for activating Power Query
Excel 2016
Power Query is included with Excel 2016 (Office 365).
It has been renamed and is now on the Data tab of
the Ribbon in the Get & Transform section.
Power Query in Excel 2016 for Windows Data Tab of
Ribbon Get and Transform
This means there is nothing to install. If you are using
Excel 2016, go to the Data tab on the ribbon and
press the New Query button to create a query and
open the Power Query editor.

Source: https://www.excelcampus.com/install-power-query

Download and install
Process for activating Power Query
Excel 2010 & 2013
For Excel 2010 and 2013 you will need to download the Power
Query add-in and install it. The installation steps are about the
same in Excel 2010 & 2013.
•

Close (exit) Excel completely.

•

Click the following link to go to the download page.

•

Click the Download button.

•

Click the checkbox for the bit version you are using. Most
likely you will be using 32-bit. And then Click Next

Source: https://www.excelcampus.com/install-power-query

•

The add-in installation file will download. Click the file
to run the installation.

•

The Setup Wizard window will open. Follow the steps
to install Power Query.

•

Once the installation is complete, open Excel. You
should now see the Power Query tab in the Ribbon.

Source: https://www.excelcampus.com/install-power-query

Download and install
Process for activating Power BI
Step 1: Download
Download the installation files, for Power BI Report Server, locally.
To download Power BI Report Server, go to the Microsoft download
center.

Step 2: Run installer
Run the PowerBIReportServer.exe file that you downloaded and step
through the installation screens. You will have the opportunity to
select the installation path as well as select the edition you want to
install. You can choose between an evaluation that expires within
180 days, a developer edition or to provide a product key

Source: https://pbiwebprod-docs.azurewebsites.net/en-us/documentation/reportserver-quickstart-install-report-server

Step 3: Configure the server
After you are done installing, you will run the configuration
manager to finish setting up your server. You will need to create
a ReportServer catalog database as well as confirm the web
portal and web service URLs.

Step 4: Browse to web portal
Now that you are configured, you should be able to open a
browser to the web portal of your server. By default, this will be
http://localhost/reports. You will also be able to browse using
the machine name instead of using localhost by default,
assuming you are not being blocked by any type of firewall.

Source: https://pbiwebprod-docs.azurewebsites.net/en-us/documentation/reportserver-quickstart-install-report-server
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For more details – Go to Power BI Live Training
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